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Overview
There are a number of sources of information on using Igor:
• The Igor Pro online manual
• The online help system
• WaveMetrics support web page
• WaveMetrics Technical Support
• The Igor mailing list
• The IgorExchange user-to-user support web page

Online Manual
The Igor Pro installer installs the entire Igor Pro manual as an Adobe PDF (portable document format) file. You 
need Adobe Reader or a comparable PDF viewer, such as Apple’s Preview, to view the online manual.

From within Igor Pro you can launch your PDF viewer program and view the online manual by choosing 
Help→Manual. From the desktop you can view the manual by double-clicking the IgorMan.pdf file in “Igor 
Pro Folder/Manual”.

The PDF manual includes a fast-search index for Acrobat Reader version 6 or later. To activate the fast 
search index, open the IgorMan.pdf file in Acrobat Reader 6 or later, choose Edit→Search, and select the 
IgorMan.pdx file.

The PDF manual is available in hard-copy form from http://www.lulu.com/wavemetrics.

WaveMetrics Support Web Page
For up-to-date information on Igor Pro, visit the WaveMetrics support Web page at:

http://www.wavemetrics.com/support/

From this web page you can search our support database, search archives of the Igor Mailing List and find 
links to updaters.

You can access this page by choosing Help→Support Web Page.

Online Help
Igor provides several forms of online help:
• The Igor help system
• Macintosh Igor Tips
• Windows status line help, context-sensitive help, and tool tips

The Igor help system is the same on Macintosh and Windows. Its major elements are Igor help files and the 
Igor Help Browser.

This table summarizes the ways to access online help in Igor.

Help Access Method What It Is Good For

The Igor Help Browser window 
(Help menu)

Finding a specific topic or subtopic in the Igor help files, learning 
about handy shortcuts, getting help for operations, functions and 
programming keywords, and searching Igor files for specific phrases.

The Help button that appears in 
many dialogs

Getting a general idea of how to use the dialog.

http://www.wavemetrics.com/support/
http://www.lulu.com/wavemetrics
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The main sources of information for help are the files in the Igor Help Files folder. Igor automatically opens 
files in this folder when it starts up.

Igor also automatically opens help files in "Igor Pro User Files/Igor Help Files" (see Igor Pro User Files on 
page II-46 for details). If you want an additional help file to be automatically opened, put it or an alias/short-
cut for it in that folder.

Addtional WaveMetrics help files can be found in "Igor Pro Folder/More Help Files". You can open these 
help files by double-clicking them or using the Open File submenu in the File menu. You can search these 
files (and all help files in the Igor Pro Folder and in the Igor Pro User Files folder) using the Search Igor Files 
tab of the Igor Help Browser.

Many Igor extensions come with help files describing their use. These help files are stored in the same folder 
as the extension itself — in either "Igor Pro Folder/Igor Extensions" or "Igor Pro Folder/More Extensions".

Igor’s help system is extensible. You can write your own help files and add balloons help or context-sensi-
tive help for your own menu items and controls. This is something that you might want to do if you write 
Igor procedures to be used by others.

Igor Tips (Macintosh)
We’ve tried to provide concise yet useful tips for nearly every menu item, dialog item and icon in Igor. 
There are two ways to show the Igor Tips window:
• Choose Help→Show Igor Tips.
• Press Option-Help.

If your keyboard lacks a Help key you must use the Help menu.

Once you’ve turned Igor Tips on, position the cursor over a menu item, dialog item or icon. In most cases, 
Igor will present a window that will explain what that item is good for.

Note: Pressing Option-Help toggles Igor Tips off or on.

You can also use Igor Tips to get information about traces in graphs and columns in tables. However, these 
Igor Tips appear only while you press Command-Option-Control and click a trace or column. Showing Igor 
Tips with the Help menu will not do it.

User-Defined Igor Tips
You can define tips for menu items and controls created by your Igor procedures. See Help for User Menus 
on page IV-108 and Help Text for User-Defined Controls on page III-382.

Status Line Help, Tool Tips and Context-Sensitive Help (Windows)
On Windows Igor provides three ways to get help for icons, menu items and dialog items. These are status 
line help, tool tips, and context-sensitive help.

Templates in procedure windows* Getting the syntax of built-in and external functions and 
operations and flow-control structures.

Igor Tips (Macintosh only) Clarifying the meaning of icons, menu items and dialog items. 
Identifying traces in graphs and columns in tables.

Status line help (Windows only) Displaying a brief description of menu items and tools.

Tool tips (Windows only) Displaying a short description of a button or tool.

Context-sensitive help (Windows only) Getting more detail than is available from the status line help.
* Chapter III-13, Procedure Windows describes the use of templates in procedure windows. This chapter 

covers the other help access methods listed in the table.
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Status Line Help
The status line area at the bottom of the main Igor Pro window shows brief descriptions of icons and menu 
items. This help is shown automatically; you don’t have to do anything to make it appear.

Tool Tips
If you point at an icon in an Igor Pro window, a tool tip will appear after a short delay. It contains just a two 
or three word description of the button.

You can adjust the delay before the tool tip appears, and the duration of display in the Help page of the 
Miscellaneous Settings dialog, which you can choose from the Misc menu.

Context-Sensitive Help
Context-sensitive help (sometimes referred to as F1 help) is displayed in a pop-up window and provides 
more detail than the status line help. It is accessed in several different ways depending on the type of item 
you need help for.

Menus

For help on items in a menu, pull down the menu and highlight the item of interest. Then press the F1 key 
to display the context-sensitive help window.

Icons

For help on icons in windows such as graphs and tables, hold down Shift and press F1. This changes the 
mouse cursor to a question-mark; click on a button or icon to display the context-sensitive help window.

Dialogs

Help for individual items in Igor’s dialogs can be summoned by clicking the question-mark button at the 
right end of the dialog’s title bar, then clicking on the item for which you want help.

Igor Shortcuts Help
Igor supports a number of very handy shortcuts. The Shortcuts tab of the Igor Help Browser lists these 
shortcuts, organized in logical categories.

Help from a Procedure Window or the Command Line
There is a quick and easy way to get help for a function, operation or flow-control keyword from the 
command line or from a procedure, notebook or help window. Type or select the name or keyword. 
Control-click (Macintosh) or right-click (Windows) and choose help from the resulting menu.

Here are some keyboard shortcuts for summoning help.

Keyboard Shortcut What It Does

Macintosh Windows

Press Help Press F1 Displays Help Browser window

Press Shift-Help Press Ctrl+F1 Inserts template for selected function, operation or flow-
control keyword

Press Shift-Option-Help Press Ctrl+Alt+F1 Shows help for selected function, operation or flow-
control keyword
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The Help Button in Dialogs
The Help button in Igor dialog’s provides an overview of the dialog and tips for using it. Use Igor Tips (Mac-
intosh) or context-sensitive help (Windows) for information on individual dialog items.

Igor Help Browser 
The Igor Help Browser is designed to provide quick access to the most frequently-used Igor reference mate-
rial and also to provide a starting point in searching for other kinds of information. You can display the Igor 
Help Browser by
• Choosing Igor Help Browser from the Help menu.
• Pressing the Help key (Macintosh) or F1 key (Windows).
• Clicking the Igor Help Browser icon in the command window.

The Igor Help Browser consists of six tabs.

Help Topics Tab
The Help Topics tab provides a table of contents for the open Igor help files. When you first launch Igor, Igor 
opens the help files in "Igor Pro Folder/Igor Help Files" and "Igor Pro User Files/Igor Help Files".

The Topics list initially presents all topics in all open help files. You can choose a specific help file from the 
Show Topics From pop-up menu to narrow the scope of topics. Once you locate and select the topic of inter-
est in the Topics list, the Subtopics list displays subtopics within that topic, if any exist.

After selecting a topic and optionally a subtopic, click the Show Selected Topic button to see the help.

If you know that the information that you are looking for is in a help file that is not normally open, for exam-
ple, in a help file associated with an Igor extension, click the Open Another Help File button. Most addi-
tional help files can be found in "Igor Pro Folder/More Help Files", "Igor Pro Folder/Igor Extensions" or 
"Igor Pro Folder/More Extensions".

If you don’t know what help file or what topic may contain the information of interest, use the Search Igor 
Files tab instead of the Help Topics tab.

Shortcuts Tab
The Shortcuts tab presents a list of shortcuts, organized in functional groups.

Command Help Tab
The Command Help tab provides quick access to reference information on Igor functions, operations and 
programming keywords. When you choose a function, operation or keyword in the list, Igor displays the 
associated help.
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A checkbox for each of the three main categories adds or removes the associated items from the list. The 
pop-up menu next to each checkbox further narrows the scope of the list.

The Copy Template button copies a template to the Clipboard which you can then paste into the command 
line or into a procedure window. All functions and operations have templates, but only some keywords do.

Here is a tip to help you understand the distinction between an operation and a function: a function returns 
a direct result (e.g., sin) while an operation does not (e.g., Display).

Search Igor Files Tab
The Search Igor Files tab provides a way for you to search Igor help files, procedure files, and notebooks for 
information of interest.
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Search Expression

The expression can consist of one or more (up to 8) terms. Terms are separated by the word “and”. Here are 
some examples:

The second example finds the exact phrase “spline interpolation” while the third example finds sections 
that contain the words “spline” and “interpolation”, not necessarily one right after the other.

The only keyword supported in the search expression is “and”. “Or” and “near” are not supported. Also, 
quotation marks in the search expression don’t mean anything special and should not be used.

If your search expression includes more than one term, a text box appears in which you can enter a number 
that defines what “and” means. For example, if you enter 10, this means that the secondary terms must 
appear with 10 paragraphs of the primary term to constitute a hit. A value of 0 means that the terms must 
appear in the same paragraph. In a plain text file, such as a procedure file, a paragraph is a single line of 
text. Blank lines count as one paragraph.

Search Folders

You can search the Igor Pro Folder and all subfolders by selecting the associated checkbox. This is intended 
for situations in which you are looking for help on Igor features or examples of Igor programming.

You can search another folder and all subfolders by selecting the Another Folder checkbox and then by 
clicking the Choose button to specify the folder. This is useful when searching your own files or if you want 
to search a specific folder inside the Igor Pro Folder.

interpolation One term

spline interpolation One term

spline and interpolation Two terms

spline and interpolation and smoothing Three terms
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Types of Files

You can choose what type of files Igor should search: help files, procedure files, notebooks, or files with a 
specific extension. You can also look for notebooks and procedure files inside packed Igor experiment files.

When Igor searches notebooks, it searches both formatted notebooks (including Igor technical notes) and 
plain text notebooks. On Macintosh, any file whose file type is 'TEXT' is considered to be a plain text note-
book. On Windows, any file whose extension is “.txt” is considered to be a plain text notebook.

On Macintosh, Igor procedure files have the file type 'TEXT'. Other kinds of plain text files, such as data 
files and readme files, also have the file type 'TEXT' so Igor can not distinguish a procedure file from some 
other kind of plain text file. When you search procedure files, it searches all plain text files in the specified 
folder and subfolders.

On Windows, procedure files use the extension “.ipf” while various kinds of plain text files use other extensions, 
such as “.dat” and “.txt”. When you search procedure files, it searches only files with the “.ipf” extension.

On both platforms, you can search files with a specific extension (“.txt”, “.dat”) using the Files With Exten-
sion checkbox.

Search Results

Igor displays hits (occurrences of the search expression) in the Search Results windoid. At the top of the 
windoid, Igor displays the total number of hits.

Each hit is displayed as a file reference, in blue text, and the contents of the paragraph containing the hit, in 
black text. To open the file containing the hit, click the blue text.

To reduce clutter, if a single paragraph contains the search expression multiple times, this is considered to 
be one hit and is displayed as one file reference.

When you click a hit that refers to a stand-alone help file, procedure file or notebook, Igor opens the file and 
displays the paragraph containing the hit, highlighting the first term in the search expression.

If you click a hit that refers to a notebook or procedure file in a packed experiment, Igor can not open the 
file directly. It presents a dialog with two options:
• Open the experiment containing the file that contains the hit.
• Create and open a copy of the file that contains the hit.

Search Strategies

Usually when you are searching for information about Igor, you should include help files and notebooks and 
you should elect to search inside packed experiment files. This is because the examples provided in the Exam-
ples folder of the Igor Pro folder are mostly in the form of packed experiment files that include an explanatory 
notebook. Igor technical notes are usually in the form of stand-alone (not packed) notebook files.

If you are searching for user-defined functions in the WaveMetrics Procedures folder, you should elect to 
search procedure files. This gives you a handy way to find a function that does something that you need or 
to find an example of Igor programming.

Search Speed

Igor’s searching does not use indexing. In other words, Igor opens and reads each file of the specified type 
or types in the specified folder or folders, and searches for the search expression. It does not store anything 
from one search to another. On slow computers, this may make searches annoyingly slow. In this case, you 
can speed things up by reducing the number of types of files to be searched or by more narrowly targeting 
the folder to be searched.

The online Igor Pro manual does provide indexed searches. This is described in the next section.

Manual Tab
The Manual tab provides a quick way for you to open the Igor Pro online manual.
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The Open Online Manual button launches your PDF viewer program and opens the IgorMan.pdf file. Igor 
expects to find IgorMan.pdf in the “Igor Pro Folder:Manual” folder, where the Igor Pro installer installs it.

The Open Online Manual button displays an error message if it can not find the IgorMan.pdf file in the “Igor Pro 
Folder:Manual” folder or if there is no program on your hard disk configured to open PDF files. In this case, 
install Adobe Acrobat Reader from the Igor Pro CD or by downloading from <http://www.adobe.com/>.

Support Tab
The Support tab lists additional sources of help with Igor Pro.

Igor Help Files
The Igor installer places help files primarily in "Igor Pro Folder/Igor Help Files" and in "Igor Pro 
Folder/More Help Files". Help files for Igor extensions are installed in "Igor Pro Folder/Igor Extensions" and 
in "Igor Pro Folder/More Extensions".

When Igor is launched it automatically opens any Igor help files in "Igor Pro Folder/Igor Help Files" and in 
"Igor Pro User Files/Igor Help Files". If you want Igor to automatically open another help file, create an alias 
(Macintosh) or shortcut (Windows) for that help file and drag it into "Igor Pro User Files/Igor Help Files" (see 
Special Folders on page II-44 for details).

Help files that you want to use occasionally can be stored anywhere on your hard disk. You can open them 
manually by double-clicking in the desktop, choosing File→Open File, or clicking the Open Another Help 
File button in the Help Topics tab of the Igor Help Browser.

Igor Help Windows
When Igor starts up, it automatically creates help windows by opening the Igor help files stored in "Igor 
Pro Folder/Igor Help Files" and in "Igor Pro User Files/Igor Help Files". You can display a help window by 
choosing it from the Help Windows submenu in the Windows menu.

Each Igor help file consists of a number of help topics, each of which may contain subtopics, and a list of 
related topics.

All of the topics are in the help file, one after another, like a big word-processing document. To see a list of 
topics, use the Igor Help Browser Help Topics tab. Blue underlined phrases are links that take you other 
parts of the help file or to other help files.

Click the Find button to search for words or phrases in the active help window. Click the Search button to 
search for words or phrases in multiple help files on disk.

A main topic.

A subtopic.

List of related topics.

Click to return to recently visited topics.

Click blue underlined text to 
view another topic.

Click to search for text 
in open window.

Click for Igor Help Browser. Search files on disk.

http://www.adobe.com/
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Clicking the Go Back button or pressing Command-B (Macintosh) or Ctrl+B (Windows) takes you back to pre-
vious places in the help that you have visited. If you also press the Shift key, Igor will hide the active help 
window if you are going back to a different help window.

Hiding and Killing a Help Window
When you click the close button in a help window, Igor hides it. It also hides the help window if you choose 
Hide from the Windows menu or press Command-W (Macintosh) or Ctrl+W (Windows).

If you are finished using an Igor help window, you can kill it. This closes the file, removes its topics from the 
Help Browser and kills the window. It does not delete the file. To kill an Igor help file, you must press Option 
(Macintosh) or Alt (Windows) while clicking the close FilterFIR or while choosing Close from the Windows menu.

Executing Commands from a Help Window
Help windows often show example Igor commands. To execute a command or a section of commands from 
a help window, select the command text and press Control-Enter or Control-Return. This sends the selected 
text to the command line and starts execution.

Compiling Help Files
Each Igor help file contains compiled help information that Igor uses to quickly find topics and subtopics. If you 
open a help file that has been modified, Igor will ask if you want to “compile” it. Compiling is what creates this 
information. This will happen only if you intentionally or accidentally modify a help file and then open it.

Windows: Prior to Igor Pro 5, Igor stored the compiled help information in a separate file with a “.igr” extension. 
Now Igor stores the compiled help information in the help file itself. The “.igr” file is no longer needed.

Creating Your Own Help File (For Advanced Users)
You can create an Igor help file that extends the Igor help system. This is something you might want to do 
if you write a set of Igor procedures or extensions for use by your colleagues. If your procedures or exten-
sions are generally useful, you might want to make them available to all Igor users. In either case, you can 
provide documentation in the form of an Igor help file.

Here are the steps for creating an Igor help file.
1. Create a formatted-text notebook.

A good way to do this is to open the Igor Help File Template provided by WaveMetrics in the More 
Help Files folder. Alternatively, you can start by duplicating another WaveMetrics-supplied help file 
and then open it as a notebook using File→Open File→Notebook. Either way, you are starting with a 
notebook that contains the rulers used to format an Igor help file.

2. Choose Save Notebook As from the File menu to create a new file. Use a “.ihf” extension so that Igor 
will recognize it as a help file.

3. Enter your help text in the new file.
4. Save and kill the notebook.
5. Open the file as a help file using File→Open File→Help File.

When you open the file as a help file, it needs to be compiled. When Igor compiles a help file, it scans through it 
to find out where the topics start and end and makes a note of subtopics. When the compilation is finished, it 
saves the help file which now includes the help compiler information.

Once Igor has successfully compiled the help file, it will act like any other Igor help file. That is, when opened it 
will appear in the Help Windows submenu, its topics will appear in the Help Browser and you can click links to 
jump around.
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Here are the steps for modifying a help file.
1. If the help file is open, kill it by pressing Option (Macintosh) or Alt (Windows) and clicking the close but-

ton.
2. Open it as a notebook, using File→Open File→Notebook.
3. Modify it using normal editing techniques.
4. Choose Save Notebook from the File menu.
5. Click the close button and kill the notebook.
6. Reopen it as a help file using File→Open File→Help File.

Syntax of a Help File
Igor needs to be able to identify topics, subtopics, related-topics declarations and links in Igor help files. To do 
this it looks for certain rulers, text patterns and text formats described in Creating Links on page II-13. You can 
get most of the required text formats by using the appropriate ruler from the Igor Help File Template file.

Igor considers a paragraph to be a help topic declaration if it starts with a bullet character followed by a tab 
and if the paragraph’s ruler is named Topic. By convention, the Topic ruler’s font is Geneva on Macintosh 
or Arial on Windows, its text size is 12 and its text style is bold-underlined. The bullet and tab characters 
should be plain, not bold or underlined.

The easiest way to create a new topic with the right formatting is to copy an existing topic and then modify it.

Once Igor finds a topic declaration, it scans the body of the topic. The body is all of the text until the next 
topic declaration, a related-topics declaration or the end of the file. While scanning, it notes any subtopics.

Igor considers a paragraph to be a subtopic declaration if the name of the ruler governing the paragraph 
starts with “Subtopic”. Thus if the ruler is named Subtopic or Subtopic+ or Subtopic2, the paragraph is a 
subtopic declaration. By convention, the Subtopic ruler’s font is Geneva on Macintosh or Arial on Windows, 
its text size is 10 and its text style is bold and underlined. Text following the subtopic name that is not bold 
and underlined is not part of the subtopic name.

The easiest way to create a new subtopic with the right formatting is to copy an existing subtopic and then 
modify it.

Igor considers a paragraph to be a related-topics declaration if the ruler governing the paragraph is named 
RelatedTopics and if the paragraph starts with the text pattern “Related Topics:”. When Igor sees this 
pattern it knows that this is the end of the current topic. The related-topics declaration is optional. Prior to 
Igor Pro 4, Igor displayed a list of related topics in the Igor Help Browser. Igor Pro no longer displays this 
list. The user can still click the links in the related topics paragraph to jump to the referenced topics.

Igor knows that it has hit the end of the current topic when it finds the related-topics declaration or when 
it finds a new topic declaration. In either case, it proceeds to compile the next topic. It continues compiling 
until it hits the end of the file.

When compiling the help file, Igor may encounter syntax that it can’t understand. For example, if you have 
a related-topics declaration paragraph, Igor will expect the next paragraph to be a topic declaration. If it is 
not, Igor will stop the compilation and display an error dialog. You need to open the file as a notebook, fix 
the error, save and kill it and then reopen it as a help file.

Another error that is easy to make is to fail to use the plain text format for syntactic elements like bullet-tab, 
“Related Topics:” or the comma and space between related topics. If you run into a non-obvious compile error 
in a topic, subtopic or related topics declaration, recreate the declaration by copying from a working help file.

The help files supplied by WaveMetrics contain a large number of rulers to define various types of paragraphs 
such as topic paragraphs, subtopic paragraphs, related topic paragraphs, topic body paragraphs and so on. 
The Igor Help File Template contains many but not all of these rulers. If you find that you need to use a ruler 
that exists in a WaveMetrics help file but not in your help file then copy a paragraph governed by that ruler 
from the WaveMetrics help file and paste it into your file. This will transfer the ruler to your file.
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Creating Links
A link is text in an Igor help file that, when clicked, takes the user to some other place in the help. Igor con-
siders any pure blue, underlined text to be a link. Pure blue means that the RGB value is (0, 0, 65535). By 
convention links use the Geneva font on Macintosh and the Arial font on Windows.

To create a link, select the text in the notebook that you are preparing to be a help file. Then choose Make Help 
Link from the Notebook menu. This sets the text format for the selected text to pure blue and underlined.

The link text refers to another place in the help using one of the following forms:

When the user double-clicks a link, Igor performs the following search:
1. If the link is a topic name, Igor goes to that topic.
2. If the link is in topic[subtopic] form, Igor goes to that subtopic.
3. If steps 1 and 2 fail, Igor searches for a subtopic with the same name as the link. First, it searches for a 

subtopic in the current topic. If that fails, it searches for a subtopic in the current help file. If that fails, it 
searches for a subtopic in all help files.

4. If step 3 fails, Igor searches all help files in the Igor Pro folder. If it finds the topic in a closed help file, it 
opens and displays it.

5. If all of the above fail, Igor displays a dialog suggesting that the required help file is not available.

You can create a link in a help file that will open a Web page or FTP site in the user’s Web or FTP browser. 
You do this by entering the Web or FTP URL in the help file while you are editing it as a notebook. The URL 
must appear in this format:

<http://www.wavemetrics.com>
<ftp://ftp.wavemetrics.com>

The URL must include the angle brackets and the “http://” or “ftp://” protocol specifier.

After entering the URL, select the entire URL (including the angle brackets) and choose Make Help Link 
from the notebook menu. Once the file is compiled and opened as a help file, clicking the link will open the 
user’s Web or FTP browser and display the specified URL.

It is currently not possible make ordinary text into a Web or FTP link. The text must be an actual URL in the 
format shown above or you can insert a notebook action which brings up a web page using the BrowseURL 
operation on page V-38. See Notebook Action Special Characters on page III-18 for details.

Checking Links
You can get Igor to check your help links as follows:
1. Open your Igor help file and any other help files that you link to.
2. Activate your help window and click at the very start of the help text.
3. Press Command-Shift-Option-H (Macintosh) or Ctrl+Shift+Alt+H (Windows). Igor will check your links 

from where you clicked to the end of the file and note any problems by writing diagnostics to the history 
area of the command window.

4. When Igor finishes checking, if it found bad links, kill the help file and open it as a notebook.
5. Use the diagnostics that Igor has written in the history to find and fix any link errors.
6. Save the notebook and kill it.
7. Open the notebook as a help file. Igor will compile it.
8. Repeat the check by going back to Step 1 until you have no bad links.

Link is help topic.

Link is in topic[subtopic] form.

Link is subtopic.
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You can abort the check by pressing Command-period (Macintosh) or Ctrl-Break (Windows) and holding it 
for a second.

The diagnostic that Igor writes to the history in case of a bad link is in the form:
Notebook $nb selection={(33,292), (33,334)} …

This is set up so that you can execute it to find the bad link. At this point, you have opened the help file as 
a notebook. Assuming that it is named Notebook0, execute
String/G nb = "Notebook0"

Now, you can execute the diagnostic commands to find the bad link and activate the notebook. Fix the bad 
link and then proceed to the next diagnostic. It is best to do this in reverse order, starting with the last diag-
nostic and cutting it from the history after fixing the problem.

When fixing a bad link, check the following:
• A link is the name of a topic or subtopic in a currently open help file. Check spelling.
• There are no extraneous blue/underlined characters, such as tabs or spaces, before or after the link. 

(You can not identify the text format of spaces and tabs by looking at them. Check them by selecting 
them and then using the Set Text Format dialog.)

• There are no duplicate topics. If you specify a link in topic[subtopic] form and there are two topics 
with the same topic name, Igor may not find the subtopic.

Updating Igor
WaveMetrics periodically releases updates for Igor. Updates provide bug fixes and new features. Updates 
are free and are usually indicated by a .01 increment in version number (e.g., 6.20 to 6.21). By contrast, 
upgrades are released roughly every two years, provide major new functionality, and usually require a pur-
chase.

Igor 6.20 or later (English version only) optionally checks during startup for available updates to the Igor 
application by contacting one of our web sites. This update check is performed on a separate processing 
thread to minimize any impact on starting Igor.

If an update is found, Igor presents a dialog in which you can choose to:

• Download the update
• Ignore the specific update
• Set the schedule for future update checks
• Disable automatic update checking
The dialog's buttons vary depending on the updates available but generally looks like this: 
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If scheduled, Igor checks for updates during the first startup of the scheduled day, or after the scheduled 
day has passed. Igor never automatically checks more than once per day. 

The frequency of automatic update checks can be set in the Updates for Igor dialog.

The default update check frequency is weekly. If this is too often, you might elect to automatically check 
once per month.

You can also completely disable the automatic update checks:

1. Choose Help→Updates For Igor to display the Updates for Igor dialog.
2. Choose Manual Check Only from the left popup menu.

You can check for updates manually by choosing Help→Updates For Igor, which presents this dialog:

Technical Support
WaveMetrics provides technical support via telephone and email.
Before contacting WaveMetrics, please gather this information so that we can help you more effectively:
• The exact version of Igor you are running. The version number is displayed in the About Igor dialog 

displayed when Igor is launched.
• Which operating system you are running.

In most cases, we need to reproduce your problem in order to solve it. It is best if you can provide a simpli-
fied example showing the problem.

Email Support
Send technical questions to us via email at:

support@wavemetrics.com

For information on upgrades and other nontechnical information, send queries to:
sales@wavemetrics.com

FTP Sites
Several FTP sites store the latest versions of Igor technical notes, utilities and user contributions. A list of 
these sites is maintained on our support web page at:

http://www.wavemetrics.com/support/

mailto:support@wavemetrics.com
http://www.wavemetrics.com/support/
mailto:sales@wavemetrics.com
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World Wide Web 
You will find our Web site at:

http://www.wavemetrics.com/

You can also choose Help→WaveMetrics Home Page.

Our Web site contains a page for searching our support database, and links to Igor-related FTP sites and to 
Igor users’ Web pages. In addition, it contains a number of cool graphs. We are always grateful for new cool 
graphs. Contact us at sales@wavemetrics.com if you have a cool graph to share.

WaveMetrics Support Web Page
The support Web page includes a searchable support database and archives of the Igor Mailing List. The 
WaveMetrics support Web address is:

http://www.wavemetrics.com/support/

You can also choose Help→Support Web Page.

Igor Mailing List
The Igor mailing list is an Internet discussion list that provides a way for Igor Pro users to help one another 
and to share solutions and ideas. WaveMetrics also uses the list to post information on the latest Igor devel-
opments. For information about subscribing and other details about the mailing list, please visit this web page:

http://www.wavemetrics.com/users/mailinglist.htm

IgorExchange
IgorExchange is a user-to-user support and collaboration web site sponsored by WaveMetrics but run by 
and for Igor users. For information about IgorExchange, please visit this web page:

http://www.igorexchange.com

Telephone Support
You can reach us at 503-620-3001 from 9 AM to 5 PM Pacific time.

It is often very helpful if you can try things on your computer while speaking to us so, if possible, call us 
from a phone near your computer.

FAX Support
You can reach our FAX machine any time at 503-620-6754.

http://www.wavemetrics.com/
mailto:sales@wavemetrics.com
http://www.igorexchange.com
http://www.wavemetrics.com/users/mailinglist.htm
http://www.wavemetrics.com/support/
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Help Shortcuts

Action Shortcut (Macintosh) Shortcut (Windows)

To activate Igor Tips Press Option-Help. —

To get a contextual menu of 
commonly-used actions

Press Control and click in the body 
of an Igor help window.

Right-click in an Igor help window.

To activate the Igor Help 
Browser

Press Help or click the Igor Help 
Browser icon in the lower-right 
corner of the command window.

Press F1 or click the Igor Help 
Browser icon in the lower-right 
corner of the command window.

To jump to a topic in an Igor 
help window

Click a blue underlined topic link 
in the help window.

Click a blue underlined topic link 
in the help window.

To jump back to recently visited 
topics

Click the Go Back button at the 
bottom of the help window or 
press Command-B.

Press Command-Shift-B to hide the 
current help window when going 
back to a different help window.

Click the Go Back button at the 
bottom of the help window or 
press Ctrl+B.

Press Shift+Ctrl+B to hide the 
current Igor help window when 
going back to a different Igor help 
window.

To execute commands in an Igor 
help window

Select the commands and press 
Control-Return or Control-Enter.

Select the commands and press 
Ctrl+Enter.

To kill a help window Option-click the close button. Press Alt and click the close button.

To insert a function or operation 
template in a procedure 
window or in the command line

Type or select the name of an Igor 
operation or function and Control-
click it or press Shift-Help.

Type or select the name of an Igor 
operation or function and right-
click it or press Ctrl+F1.

To get help for a function or 
operation from a procedure, 
notebook or help window or 
from the command line

Type or select the name of an Igor 
operation or function and Control-
click it or press Shift-Option-Help.

Type or select the name of an Igor 
operation or function and right-
click it or press Ctrl+Alt+F1.
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