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Overview
A page layout, or layout for short, is a type of window that you can use to compose pages containing:
• graphs
• tables
• annotations (textboxes and legends)
• pictures
• drawing elements (lines, arrows, rectangles, polygons, etc.)

Each layout represents one page. You can have as many layouts as memory allows.

Here is an example of a layout window.

A page layout has a number of layers. One layer, the layout layer, is for graphs, tables, annotations and pic-
tures. The other layers are for drawing elements. Drawing is discussed in detail in Chapter III-3, Drawing. 
This chapter is primarily devoted to the layout layer.

Here are the notable features of page layouts.
• You can combine graphs, tables, pictures, annotations and drawing elements.
• Graphs, tables and legends in layouts are updated automatically.
• Complex graphs can be quickly and smoothly positioned.
• Layouts print at the full resolution of the printer.
• You can export all or part of a layout to another program.

There are two ways to add a graph or table to the layout layer:
• By creating a graph or table object. An object is a representation of a separate standalone graph or 

table window. Layout objects are described under Objects in the Layout Layer on page II-370.

Dotted line encloses the 
printable part of the page.

Page layout tools 
are currently active

Annotations

Graphs

A draw element

Information Panel

Draw icon — click to 
use drawing tools

Layout icon — click to 
use page layout tools

A table

Zoom Control
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• By creating an embedded graph or table subwindow. A subwindow is a self-contained graph or table 
embedded in a layout window. Embedded subwindows are described under Subwindows in the 
Layout Layer on page II-372.

The subwindow is a power-user feature added in Igor Pro 5. It is described in detail in Chapter III-4, 
Embedding and Subwindows and can not be effectively used without a careful reading of that chapter. 
Graph and table objects are less powerful but simpler to use and more intuitive. We recommend using 
graph and table objects until you have had time to read and understand Chapter III-4.

In this chapter, the term “object” refers to graph, table, annotation and picture objects, not to graph or table 
subwindows.

Memory Usage in Page Layouts
Igor uses techniques that make the layout layer operate quickly and smoothly even when you are working 
with large, complex graphs. These techniques require that Igor store an image of the page in memory.

If you view a layout in color and then change the number of colors displayed on your monitor, Igor will 
update the layout using the new number of colors. If Igor runs out of memory while doing this, it will 
reduce the page magnification so that less memory is required.

Layout Background Color
You can choose a background color for a page layout. This is useful for creating slides.

You can specify a background color for the page layout by:
• Using the Background Color submenu in the Layout menu.
• Using the Background Color submenu in the Misc pop-up menu.
• Using the NewLayout command line operation.
• Using the ModifyLayout command line operation.

The background color is white by default. If you wish, after selecting a background color, you can capture 
your preferred background color by choosing Capture Layout Prefs from the Layout menu.

Layers
A page in a layout has five layers. There is one layer for layout objects and four layers for drawing elements.

The two icons in the top-left corner of the layout window control whether you are in layout mode or 
drawing mode.

All graphs, tables and annotations 
go in the Layout layer.

Most manual drawing is done in the 
User Front layer.

UserFront

ProgFront

Layout

UserBack

ProgBack
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The layout layer is most useful for presenting multiple graphs and for annotations that refer to multiple 
graphs. The drawing layers are useful for adding simple graphic elements such as arrows between graphs.

Activating the Layout Layer
When you click the layout icon, the layout layer is activated. You can use the layout tools to add objects to 
or modify objects in the layout layer only.

Activating the Current Drawing Layer
When you click the drawing icon, the current drawing layer is activated. You can use the drawing tools to 
add elements to or modify elements in the current drawing layer only.

Changing the Current Drawing Layer
Initially, the UserFront drawing layer will be the current drawing layer. To select a different drawing layer, 
press Option (Macintosh) or Alt (Windows) and click the drawing environment pop-up icon.

You may never need to use the Drawing Layer pop-up menu. Most users will need to use just the layout 
layer and the UserFront drawing layer. The ProgFront and ProgBack layers are intended to be used from 
Igor procedures only.

Layout Mode icon — activates the layout layer.

Draw Mode icon — activates the selected draw layer.

When the layout icon is highlighted, the layout layer 
and layout tools are activated.

Arrow tool — selects, moves or resizes a layout object

Marquee tool — identifies layout objects to cut, copy or tile

Annotation tool — creates or modifies textboxes and legends

Frame tool — sets frame for the selected layout object

Misc pop-up menu — controls units update mode

Graph pop-up menu — inserts a graph layout object

Table pop-up menu — inserts a table layout object

When the drawing icon is highlighted, the current 
drawing layer and drawing tools are activated.

Arrow or selector tool

Simple text tool

Lines and arrows tool

Rectangle tool

Rounded rectangle tool

Oval tool
Polygon tool

Drawing environment pop-up

Mover pop-up

Option-click or Alt-click the 
drawing environment icon

to get the Draw Layer pop-up menu:
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If you click an element that is not in the active layer, Igor will ignore the click.

DelayUpdate and Drawing Commands
There is a DelayUpdate setting, accessible via the Misc pop-up menu, that controls when the layout will be 
redrawn. If you execute drawing commands from the command line or from a procedure and if the Del-
ayUpdate setting is on, the layout will not be updated until you make it the active window. Therefore, if 
you want to type drawing commands in the command line and see the effect in the layout immediately, 
turn the DelayUpdate setting off.

For Further Information on Drawing Layers
The drawing layers function nearly identically in graph, page layout and control panel windows. For 
details on drawing, see Chapter III-3, Drawing. The rest of this chapter discusses drawing only to describe 
behavior that is unique to layout windows.

Creating a Layout
You create a layout by choosing New Layout from the Windows menu.

You can create a layout with no objects in it by clicking Do It without selecting any objects. You can append 
objects to the layout later.

Layout Menu
The Layout menu contains items that apply to page layout windows only. It appears in the menu bar only 
when the active window is a layout.

Choose a layout style macro, if any. 
Usually, there will be no style macro

Select objects to put 
into the layout layer. 
Shift-click to select 
multiple objects.

Enter a title for the 
layout here or leave 
this blank to get a 
default title.

Select to initially tile or stack the 
objects. It is often preferable to 
leave these deselected and to use 
the Arrange Objects dialog later.

These apply to the selected 
layout object.

Sets object size, position, 
frame and other properties.

For tiling or stacking layout objects.

Adds a textbox or legend to the layout layer.
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Layout Names and Titles
Every layout that you create has a name. This is a short Igor-object name that you or Igor can use to refer-
ence the layout from a command or procedure. When you create a new layout, Igor assigns it a name of the 
form Layout0, Layout1 and so on. You will most often use a layout’s name when you kill and recreate the 
layout, see Killing and Recreating a Layout on page II-369.

A layout also has a title. The title is the text that appears at the top of the layout window. Its purpose is to 
identify the layout visually. It is not used to identify the layout from a command or procedure. The title can 
consist of any text, up to 255 characters.

You can change the name and title of a layout using the Window Control dialog. This dialog is a collection of 
assorted window-related things. Choose Window Control from the Control submenu of the Windows menu.

Hiding and Showing a Layout
You can hide a layout by Shift-clicking the close button.

If the Minimize Is Hide checkbox is selected in the Miscellaneous Settings dialog (Misc menu), you can hide 
a layout by clicking its minimize icon and hide all layouts by clicking the minimize button while pressing 
Option (Macintosh) or Alt (Windows).

You can show a layout by choosing its name from the Windows→Layouts submenu.

Killing and Recreating a Layout
Igor provides a way for you to kill a layout and then later to recreate it. This temporarily gets rid of a layout 
that you expect to be of use later.

You kill a layout by clicking the layout window’s close button or by using the Close item in the Windows menu. 
When you kill a layout, Igor offers to create a window recreation macro. Igor stores the window recreation 
macro in the procedure window of the current experiment. You can invoke the window recreation macro later 
to recreate the layout. The name of the window recreation macro is the same as the name of the layout.

For further details, see Closing a Window on page II-59 and Saving a Window as a Recreation Macro on 
page II-61.

Page Setups
The page setup is a collection of information created by the printer driver. It controls the page orientation, 
the dimensions of the page, and the size of page margins. You can modify it using the Page Setup dialog 
via the File menu or using the PrintSettings operation on page V-503.

Each page layout has its own associated page setup. When you create a new page layout, Igor creates a new, 
default page setup. You can change the default page setup to get the page orientation and margins that you 

The Window Control dialog changes 
a layout’s title and name.
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prefer using the Capture Layout Prefs item in the Layout menu. Igor uses this captured page setup when 
you create a layout interactively. To use the captured page setup from an Igor procedure, see the Prefer-
ences operation on page V-497.

When you close a layout window, Igor asks if you want to create a layout recreation macro. If you do create 
the macro, you can execute it later to recreate the layout. Igor then reuses the layout’s original page setup 
for the recreated layout.

Page setups are stored in the experiment file when you save the current experiment.

Changing Printers
Page setups are customized for each printer. When you change printers and then attempt to print, some 
printer drivers try to convert the page setup for the old printer into an equivalent page setup for the new 
printer. This conversion is not always accurate. If you find that printing behaves unexpectedly when you 
change printers, then you will need to use the Page Setup dialog to fix the page setup before you print.

Changing Computer Platforms
When you transfer an experiment saved by Igor Pro 3.0 or earlier from Macintosh to Windows, page setups 
are lost. Igor will use a default setup for all page layouts in the experiment.

When you transfer an Igor Pro 3.1 (or later) experiment from one platform to another, page setup records 
are only partially preserved. Igor attempts to preserve the page orientation and margins.

There is a more detailed discussion of this issue in Chapter III-15, Platform-Related Issues.

Zooming
You can zoom the page in to 200% or out to 50% or 25%. Use the Zoom submenu in the Layout menu or the 
Zoom pop-up menu in the lower-left corner of the layout window.

By zooming out you see the entire page at once. You can zoom in to place drawing elements with higher 
precision.

Igor stores the position of layout objects with a precision of one point. Therefore, zooming in does not allow 
you to position them more precisely. Also, when you zoom in, Igor does not redraw graphs and other 
objects in the layout layer; it merely shrinks or expands a stored representation of the object. However, Igor 
does redraw graph and table subwindows and drawing elements.

Objects in the Layout Layer
The layout layer can handle four kinds of objects: graphs, tables, annotations and pictures. This table shows 
how you can add each of these objects to the layout layer.

Object Type To Add Object to the Layout Layer

Graph Use the Graph pop-up menu in the layout window.
Use the Append to Layout dialog.
Use the AppendLayoutObject operation in user-functions, otherwise use the 
AppendToLayout operation.

Table Use the Table pop-up menu in the layout window.
Use the Append to Layout dialog.
Use the AppendLayoutObject operation.
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Layout Object Names
Each object in the layout layer has a name so that you can manipulate it from the command line or from an 
Igor procedure as well as with the mouse. When you position the cursor over an object, its name, position 
and dimensions are shown in the info panel at the bottom of the layout window.

For a graph or table, the object name is the same as the name of the graph or table window. For an annota-
tion, the object name is determined by the Textbox or Legend operation that created the annotation. When 
you paste a picture from the Clipboard into a page layout, Igor automatically gives it a name like PICT_0 
and adds it to the current experiment’s picture collection.

Layout Object Properties
This table shows the properties of each object in the layout layer.

All of the properties can also be set using the ModifyLayout operation from the command line or from an 
Igor procedure.

Some special cases involving layout object transparency are discussed under Problems with Layouts on 
page II-389.

Annotations Click the text (“A”) tool and then click in the page area.
Use the Add Annotation dialog.
Use the TextBox or Legend operations.

Pictures Paste from the Clipboard.
Use the Pictures dialog (Misc menu).
Use the AppendLayoutObject operation if the picture already exists in the current 
experiment’s picture collection.

Object Property Comment

Left coordinate Measured from the left edge of the paper.

Set using mouse or Modify Objects dialog.

Top coordinate Measured from the top edge of the paper.

Set using mouse or Modify Objects dialog.

Width Set using mouse or Modify Objects dialog.

Height Set using mouse or Modify Objects dialog.

Frame None, single, double, triple, or shadow.

Set using Frame pop-up menu or Modify Objects dialog.

Transparency Set using Modify Objects dialog.

Fidelity Set using Modify Objects dialog.

This affects only what happens when you resize an object. If you resize a high 
fidelity object, Igor redraws the object completely at the new size. If you resize a low 
fidelity object, Igor stretches an existing picture of the object to fit the new size.

As of Igor Pro 6.1, the fidelity setting no longer affects graph objects.

Object Type To Add Object to the Layout Layer
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Dummy Objects
If you append a graph or table to the layout layer, this creates a corresponding layout object. If you then kill 
the graph or table window, the layout object remains and is said to be a “dummy object”. A dummy object 
can be moved, resized or changed just as any other object.

If you later recreate the graph or table window or create a new graph or table with the same name as the 
original, the object is reassociated with the window and ceases to be a dummy object.

Automatic Updating of Layout Objects
Graph and table objects are dynamic. When a graph or table changes, Igor automatically updates the cor-
responding layout object. Also, if you change the symbol for a wave in a graph and if that symbol is used 
in a layout legend, Igor automatically updates the legend.

Normally, Igor waits until the layout window is activated before doing an auto-
matic update. You can force Igor to do the update immediately by deselecting 
the DelayUpdate item in the Misc pop-up menu in the layout’s tool palette.

See DelayUpdate and Drawing Commands on page II-368 for information on 
how DelayUpdate affects drawing elements.

Subwindows in the Layout Layer
The layout layer can handle two kinds of subwindows: graphs and tables. To add a subwindow to a layout:
1. Activate the layout layer by clicking the layout icon.
2. Select the marquee tool (dashed-line rectangle).
3. Drag out a marquee.
4. Click inside the marquee and choose New Graph Here or New Table Here.

You can also create a subwindow by right-clicking (Windows) or Control-clicking (Macintosh) while in 
drawing mode and choosing an item from the New submenu.

You can convert a graph or table object to an embedded subwindow by right-clicking (Windows) or Control-
clicking (Macintosh) while in layout mode and choosing Convert To Embedded. Note that a graph contain-
ing a control panel or controls cannot be converted into an embedded graph, even though a graph object 
with controls or control panels can be added to a layout. Such a graph object does not display the controls 
or control panels, however.

You can convert a graph or table subwindow to a graph or table object by right-clicking (Windows) or Control-
clicking (Macintosh) while in layout mode and choosing Convert To Graph And Object or Convert To Table 
and Object. In a graph window, you must click in the graph background, away from any traces or axes.

The subwindow is a power-user feature added in Igor Pro 5. It is described in detail in Chapter III-4, 
Embedding and Subwindows and can not be effectively used without a careful reading of that chapter.
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Layout Layer Tool Palette

Arrow Tool 
When you click the arrow tool, it becomes highlighted. The arrow tool is used 
to select, move or resize a graph, table, annotation or picture object. To select 
an object, click it. Adjustment handles appear on the selected object.

When you position the cursor over an object, the info panel shows the name of 
the object under the cursor. If you drag, the cursor changes to a hand and the 
object will follow the cursor as you drag it. While you drag, the info panel 
shows the left and top coordinates of the object as well as its width and height.

If you press Shift while dragging an object, the direction of movement is con-
strained either horizontally or vertically, depending on the first motion direc-
tion. If you momentarily release Shift and press it again, you can change the 
direction of constraint.

By dragging the selected object’s handles, you can set the object’s width and height. While you drag, the info 
panel shows the width and height of the object. If the object you are adjusting is a table, the info panel also shows 
the width and height of the table in terms of rows and columns. If the object you are adjusting is an annotation 
or picture, the info panel also shows the width and height of the object in terms of percent of its unadjusted size.

If you press Shift while dragging a corner handle, the resize will be proportional so that the object will main-
tain its original aspect ratio. The resize may deviate from precisely proportional if the page layout magni-
fication is less than 100 percent.

When you adjust the size of a table and then release the mouse, the table is auto-sized to an appropriate 
integral number of rows and columns. To disable the auto-sizing, press Option (Macintosh) or Alt (Windows) 
while resizing the table.

You can quickly force an annotation or picture back to its unadjusted size (100% by 100%) by pressing Option 
(Macintosh) or Alt (Windows) and double-clicking the object. You can auto-size a table using the same method.

Double-clicking an object while the arrow tool is selected brings up the Modify Objects dialog, described in 
Modifying Layout Objects on page II-380. Use this dialog to set the object’s properties.

When two or more objects are selected, you can align them using the Align submenu in the Layout menu. 
You can also make the widths, heights, or widths and heights of the selected objects the same using items 
in the Layout menu. In all of these actions, the first object that you select is used as the basis for aligning or 
resizing other objects. Click in a blank area of the page to deselect all objects. Then click the object whose 
position or size you want to replicate. Now Shift-click to select additional objects. Finally, choose the 
desired action from the Layout menu.

While an object is selected, you can control its front-to-back ordering in the layout layer by choosing Bring 
to Front, Move Forward, Send to Back or Move Backward from the Layout menu. This changes the order 
of objects within the layout layer only. It has no effect on the drawing layers.

If you select a graph or table object, you can then double-click the name of the object in the info panel at the 
bottom of the layout window. This activates the associated graph or table window.

After selecting an object by clicking it, you can select additional objects by Shift-clicking. If you Shift-click 
an object that is already selected, it becomes deselected.

You can also select multiple objects by drag-clicking. Start by clicking in an area of the page where there are 
no objects. With the mouse button held down, drag the mouse diagonally. While you do this, Igor displays 
a gray selection rectangle. Drag the rectangle until it completely encloses all of the objects that you want to 
select. You can select additional objects by pressing Shift while drag-selecting unselected objects. You can 
deselect objects by pressing Shift while drag-selecting selected objects. You can also deselect objects by 
pressing Shift and clicking them.
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With multiple objects selected, you can perform the following actions:
• Delete the objects, using the Delete key or the Edit→Clear menu item.
• Copy the objects, using Edit→Copy.
• Cut the objects, using Edit→Cut.
• Drag the objects to a new location.
• Nudge the objects with the arrow keys.
• Change the frame on the objects using the frame tool.

You can not do the following actions on multiple objects:
• Change the order of the objects in the object list (move to front, move to back).
• Adjust the size of the objects using the mouse.

Marquee Tool 
When you click the marquee tool, it becomes highlighted and the cursor changes to a crosshair. You can use the 
marquee tool to identify multiple objects for cutting, copying, clearing or arranging. You can also use it to indi-
cate a part of the layout for export to another application and to control pasting of objects from the Clipboard.

To use the marquee tool, click the mouse and drag it diagonally to indicate the region of interest. Igor dis-
plays a dashed outline around the region. This outline is called a marquee. A marquee has handles and 
edges that allow you to refine its size and position.

To refine the size of the marquee, move the cursor over one of the handles. The cursor changes to a double 
arrow which shows you the direction in which the handle adjusts the edge of the marquee. To adjust the 
edge, simply drag it to a new position.

To refine the position of the marquee, move the cursor over one of the edges away from the handles. The 
cursor changes to a hand. To move the marquee, drag it.

To make it possible to export any section of a layout, an object is considered selected if it intersects the mar-
quee. This is in contrast to selection with the arrow tool, which requires that you completely enclose the object.

This table shows how to use the marquee.

When you click inside the marquee Igor presents a pop-up menu, called the Layout Marquee menu, from 
which you can choose Cut, Copy, Paste, or Clear. This cuts, copies, pastes or clears the all objects that inter-
sect the marquee. These marquee items do the same thing as the corresponding items in the Edit menu.

The Marquee menu also contains items that allow you to insert a graph or table subwindow.

It is possible to add your own menu items to the Layout Marquee menu. See Marquee Menus on page 
IV-119 for details.

To Accomplish This Do This

Cut, copy or clear multiple objects Drag a marquee around them and then use the Edit menu to cut, 
copy or clear.

Paste objects into a particular area Drag a marquee where you want to paste and then use the Edit 
menu to paste.

Tile or stack objects Drag a marquee to indicate the area into which you want to tile or 
stack and then choose Arrange Objects from the Layout menu.

Export a section of the layout as a 
picture

Drag a marquee to indicate the section that you want to export and then 
choose Export Graphics from the Edit menu (to use the Clipboard) or 
choose Save Graphics from the File menu (to save in a disk file).
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See Copying Objects from the Layout Layer on page II-387 and Pasting Objects into the Layout Layer on 
page II-387 for more details on copying and pasting. See Arranging Objects on page II-385 for details on 
tiling and stacking.

When the marquee tool is selected, any selected object is deselected. Double-clicking while the marquee tool 
is selected has no effect.

Annotation Tool 
When you click the annotation tool, it becomes highlighted and the cursor changes to an I-beam. The annotation 
tool creates new annotations or modifies existing annotations. Annotations include textboxes and legends.

Clicking an existing annotation invokes the Modify Annotation dialog. Clicking anywhere else on the page 
invokes the Add Annotation dialog which you use to create a new annotation. See Annotations in the 
Layout Layer on page II-381 for more details.

Frame Pop-Up Menu 
When an object is selected, you can change its frame by selecting an item from the Frame pop-up menu. 
Each object can have no frame or a single, double, triple or shadow frame.

When you change the frame of a graph, table or picture object, its outer dimensions (width and height) do 
not change. Since the different frames have different widths, the inner dimensions of the object do change. 
In the case of graphs this is usually the desired behavior. For tables, changing the frame shows a nonintegral 
number of rows and columns. You can restore the table to an integral number of rows and columns by 
pressing Option (Macintosh) or Alt (Windows) and double-clicking the table. For pictures, changing the 
frame slightly resizes the picture to fit into the new frame. To restore the picture to 100% sizing, press 
Option (Macintosh) or Alt (Windows) and double-click the picture.

When you change the frame of an annotation object, Igor does change the outer dimensions of the object to 
compensate for the change in width of the frame.

Misc Pop-Up Menu 
The Misc pop-up menu adjusts some miscellaneous settings related to the layout.

You can choose Points, Inches, or Centimeters. This sets the units used in the info panel.

You can enable or disable the DelayUpdate item. If DelayUpdate is on, when a graph or table which corre-
sponds to an object in the layout changes, the layout is not updated until you activate it (make it the front 
window). If you disable DelayUpdate then changes to graphs or tables are reflected immediately in the 
layout. This also affects drawing commands. If you want to see the effect of drawing commands immedi-
ately, turn the DelayUpdate setting off.

DelayUpdate does not affect embedded graph and table subwindows.

Prior to Igor Pro 6.10, DelayUpdate was a per-document setting. It is now a global setting that affects all 
existing and future layouts instead of just the layout you set.

You can use the Background Color submenu to change the layout’s background color. See Layout Back-
ground Color on page II-366 for details.

Graph Pop-Up Menu 
The Graph pop-up menu provides a handy way to append a graph object to the layout layer. It contains a list 
of all the graph windows that are currently open. Choosing the name of a graph appends the graph object to 
the layout layer. The initial size of the graph object in the layout is taken from the size of the graph window.



Chapter II-16 — Page Layouts

II-376

Table Pop-Up Menu 
The Table pop-up menu provides a handy way to append a table object to the layout layer. It contains a list 
of all the table windows that are currently open. Choosing the name of a table appends the table object to 
the layout layer.

The Layout Layer Contextual Menu
When the layout layer is active, Control-clicking (Macintosh) or right-clicking 
(Windows) displays the Layout Layer contextual menu. The contents of the 
menu depend on whether you click directly on an object or on a part of the 
page where there is no object.

Activate Object’s Window
This item activates the corresponding graph or table window.

Recreate Object’s Window
This item recreates the corresponding graph or table window by running the window recreation macro that 
was created when the window was killed.

Kill Object’s Window
This item kills the corresponding graph or table window. Before it is killed, you will see a dialog you can 
use to create or update its window recreation macro.

If you press Option (Macintosh) or Alt (Windows) while selecting this item, the window will be killed with 
no dialog and without creating or updating the window recreation macro. Any changes you made to the 
window will be lost so use this feature carefully.

Windows Only:Pressing Alt while right-clicking does not work. To use the Alt key feature, proceed as 
follows: right-click, then select the menu item without releasing the left mouse button, 
then press Alt, then release the left mouse button.

Show Object’s Window
This item shows the corresponding graph or table window if it is hidden.

Hide Object’s Window
This item hides the corresponding graph or table window if it is hidden.

Scale Object
This item changes the size of the layout object in terms of percent of its current size or percent of its normal size. 
Although this can work on any type of object, it is most useful for scaling pictures relative to their normal size.

For a picture or annotation object, “normal” size is the inherent size of the picture or annotation before any 
shrinking or expanding. For a graph or table object, “normal” size means the size of the corresponding 
graph or table window.

Regardless of the scaling values you enter, Igor does not allow the size of any object to exceed the size of 
the entire page.

If a graph’s size is hardwired via the Modify Graph dialog, the corresponding layout object can not be scaled.

Tip: You can quickly return a picture or annotation to its normal size by double-clicking it while 
pressing Option (Macintosh) or Alt (Windows).
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Convert Object to Embedded
This item converts a graph or table object to an embedded subwindow. In doing so, the separate graph or 
table window which the object represented is killed, leaving just the embedded subwindow.

If you Control-click or right-click on a part of the page where there is no object, the Layout contextual menu 
looks like this:

Recreate Selected Objects’ Windows
This item runs the recreation macro for each selected graph or table object for which the corresponding 
window was killed. It does nothing for selected picture or annotation objects.

Kill Selected Objects’ Windows
This item kills the window corresponding to each selected graph or table object. It does nothing for selected 
picture or annotation objects. Before each window is killed, you will see a dialog you can use to create or 
update its window recreation macro.

If you press Option (Macintosh) or Alt (Windows) while selecting this item, each window will be killed with 
no dialog and without creating or updating the window recreation macro. Any changes you made to the 
window will be lost so use this feature carefully.

Scale Selected Objects
This item changes the size of each selected layout object in terms of percent of its current size or percent of 
its normal size.

Appending a Graph or Table to the Layout Layer
You can append graphs and tables to a layout by choosing the Append to Layout item from the Layout menu.

You can also append a graph or table using the pop-up menus in the layout’s tool palette.

Inserting a Picture in the Layout Layer
You can insert a picture that you have created in another application, for example a drawing program, into 
the layout layer. (You can also insert a picture into the drawing layers. This is recommended if you wanted 
to group the picture with other drawing elements.)

Select to Tile or Stack. 
You can also tile or stack 
later using the Arrange 
Objects dialog.

Select graphs and tables 
to append. Shift-click to 
select multiple objects.
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You can insert a picture in a layout by copy-and-paste or by loading from a file. When loading from a file 
you must go through Igor’s picture collection (Misc→Pictures) to load and then place the picture.

Here are the supported picture formats:

PDF is the standard format for Mac OS X graphics. PICT was used prior to OS X and can still be pasted or place 
in layouts but is obsolete.

EMF is the standard format for Windows graphics. Both of these are platform-dependent and will display as 
gray boxes if you move the Igor experiment to the other platform. The other formats are platform-independent. 
For more details, see Picture Compatibility on page III-395.

If you will be exporting your page layout to an EPS file or printing to a Postscript printer, you will get the 
best results if your imported pictures are EPS. There are some restrictions on exporting a layout that con-
tains pictures as EPS. If you plan to do this, see Chapter III-5, Exporting Graphics (Macintosh), or Chapter 
III-6, Exporting Graphics (Windows), for details.

All pictures used in the layout layer or in the drawing layers are stored in the current experiment’s picture 
collection. You can examine the picture collection, load pictures into it and remove pictures from it using 
the Pictures dialog. This is described in greater detail in the section Pictures on page III-421.

This diagram shows the two methods for putting a picture into a layout and how this relates to the picture 
collection.

Format How To Place Notes

PDF Paste or use Misc→Pictures Macintosh only

EMF (Enhanced 
Metafile)

Paste or use Misc→Pictures Windows only

BMP (bitmap) Use Misc→Pictures Windows only

BMP is sometimes called DIB (device-independent 
bitmap).

PNG (Portable 
Network Graphics)

Use Misc→Pictures Cross-platform bitmap format

JPEG Use Misc→Pictures Cross-platform bitmap format

TIFF (Tagged Image 
File Format)

Use Misc→Pictures Cross-platform bitmap format

EPS (Encapsulated 
PostScript)

Use Misc→Pictures High resolution vector format. Requires PostScript 
printer. A screen preview is displayed on screen.
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Pasting a picture from the Clipboard or loading it from a file puts the picture into the experiment’s picture 
collection and auto-names it.

Placing a Picture
Here is the Pictures dialog.

When you click Place Picture In Layout, Igor closes the Pictures dialog and displays an angle-bracket 
cursor. If you drag out a rectangle in the page with the angle-bracket, Igor will paste the picture into that 
rectangle. If you just click with the angle-bracket, Igor will paste the picture at its default size, putting the 
top-left corner of the picture where you clicked.

You can’t scroll or zoom the page layout while the angle-bracket cursor is active. Therefore, you may need 
to adjust the picture after placing it.

You can always reset a picture to its default size by pressing Option (Macintosh) or Alt (Windows) and 
double-clicking it with the arrow tool.

Place

PICT file or
Enhanced Metafile

Picture Collection

PICT_0P
as

te

Load

PICT_1

Clipboard

Page Layout

Select the picture and then 
click the Place button
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Removing Objects from the Layout Layer
You can remove objects from a layout by choosing the Remove from Layout item from the Layout menu.

You can also remove objects by selecting them with the arrow tool or enclosing them with the marquee tool 
and pressing Delete or by selecting the Clear or Cut items from the Edit menu.

Removing a picture from a layout does not remove it from the picture collection. To do this, use the Pictures 
dialog.

Modifying Layout Objects
You can modify the properties of layout objects using the Modify Objects dialog. To invoke it, choose 
Modify Objects from the Layout menu or double-click an object with the arrow tool.

The effect of each property is described under Layout Object Properties on page II-371.

Once you have modified an object you can select another object from the Object list and modify it.

High Fidelity
The High Fidelity property determines how a layout object is redrawn when it is resized. If selected, the 
object is fully redrawn. If deselected (low fidelity mode), a stored picture of the object is stretched to fit the 
new size. As of Igor Pro 6.1, this property does not affect graph objects which are always drawn in high 
fidelity.

The low fidelity mode was created for speed considerations at a time when personal computers ran at 16 
MHz. Now there is rarely any reason to use it.

Select the objects to remove. 
Shift-click to select multiple 
objects.

Measured from the top-left corner of the paper.

Select the object to remove. 
You can select only one 
object at a time.
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Annotations in the Layout Layer
The term “annotation” includes textboxes, legends and tags. You can create annotations in graphs and lay-
outs. Annotations are discussed in detail in Chapter III-2, Annotations. This section discusses aspects of 
annotations that are unique to page layouts.

In a graph, an annotation can be a textbox, legend or tag. A legend shows the plot symbols for the waves in 
the graph. A tag is connected to a particular point of a particular wave. In a layout, tags are not applicable. 
You can create textboxes and legends.

Don’t confuse annotations with the simple text elements that you can create in the drawing layers of graphs, 
layouts and control panels. These simple text elements are intended for specialized purposes, such as creating 
axes that Igor doesn’t directly support (e.g. polar axes). Annotations are intended for general purpose labeling.

Creating a New Annotation
To create a new annotation, choose Add Annotation from the Layout menu or select the annotation tool and click 
anywhere on the page, except on an existing annotation. These actions invoke the Add Annotations dialog.

The many options in this dialog are explained in Chapter III-2, Annotations.

Modifying an Existing Annotation
If an annotation is selected when you pull down the Layout menu, you will see a Modify Annotation item 
instead of the Add Annotation item. Use this to modify the text or style of the selected annotation. You can 
also get to the Modify Annotation dialog by clicking the annotation while the annotation tool is selected. 
Double-clicking an annotation while the arrow tool is selected brings up the Modify Object dialog, not the 
Modify Annotation dialog.

Positioning an Annotation
An annotation is positioned relative to an anchor point on the edge of the printable part of the page. The dis-
tance from the anchor point to the textbox is determined by the X and Y offsets which are in percent of the 
printable page. The X and Y offsets are automatically set for you when you drag a textbox around the page. 
You can also set them using the annotation Tweaks subdialog but this is usually not as easy as just dragging.

Choose Textbox 
or Legend.

Enter or edit text 
here.
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Positioning Annotations Programmatically
This diagram shows the anchor points. You don’t need to know this to position annotations by dragging. 
You do need to know it to position them programmatically, from an Igor procedure.

Using the top-left anchor, a (0, 0) XY offset would put a tag in the top-left corner of the page:
Textbox/A=LT/X=0/Y=0 "Test 1"

An XY offset of (50, 50) would put a tag in the middle of the page.
Textbox/A=LT/X=50/Y=50 "Test 2"

Using the middle-center anchor, a (0, 0) XY offset would put a tag in the middle of the page:
Textbox/A=MC/X=0/Y=0 "Test 3"

An XY offset of (-50, 50) would put a tag in the top-left corner of the page.
Textbox/A=MC/X=-50/Y=50 "Test 4"

For most purposes, the left-top anchor is the easiest to use and is sufficient.

The anchor sets not only the reference point on the page but also the reference point on the annotation. For 
example, if the anchor is right-top then the XY offset sets the position of the right-top corner of the annota-
tion, relative to the right-top corner of the page. For this reason, if you want several textboxes to be right-
aligned, you would want to use a right-top, right-center or right-bottom anchor.

Legends in the Layout Layer
When you invoke the Add Annotations dialog and choose Legend, Igor automatically sets the annotation’s 
text to produce a legend containing a symbol for each wave in each graph object in the layout. In the picture 
of the dialog above, you can see the text that Igor generated. This diagram explains it.

Left-bottom Middle-bottom Right-bottom

Left-center Middle-center Right-center

Left-top Middle-top Right-top

Escape code for 
wave trace symbol

Specifies the graph Specifies the trace in the graph

\s(Graph0.data0) data0
\s(Graph1.data1) data1
\s(Graph2.data2) data2

 data0
 data1
 data2

You can put any text here
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Igor generates the lines of the legend text starting with the bottom graph object in the layout and working 
toward the top. You can edit the text to remove symbols that you don’t want or to change what appears 
after the symbol.

If you change the symbol for a trace referenced in the legend, Igor will automatically update the layout 
legend. If you append or remove waves to the graphs represented in the layout, Igor will also update the 
layout legend. Updating happens when you activate the layout unless you have turned the layout’s Del-
ayUpdate setting off, in which case it happens immediately.

You can freeze a legend by converting it to a textbox. This stops Igor from automatically updating it when 
waves are added to or removed from graphs. To do this, select the annotation tool and click in the legend. 
In the resulting Modify Annotation dialog, change the pop-up menu in the top-left corner from Legend to 
Textbox. You can also do this using the following command:
Textbox/C/N=text0 // convert legend named text0 into a textbox

Instead of specifying the name of the trace for a legend symbol, you can specify the trace number. For exam-
ple, "\s(Graph0.#0)" displays the legend for trace number 0 of Graph0.

Default Font
By default, annotations use the default font chosen in the Default Font dialog via the Misc menu. You can 
override the default font using the Font pop-up menu in the Add Annotation dialog. If you change the 
default font, Igor will automatically update the layout. This will happen when you activate the layout or 
immediately if you have disabled the layout’s DelayUpdate setting.

Front-To-Back Relationship of Objects
New objects added to the layout layer are added in front of existing objects. You can 
move objects in front of or in back of other objects using the Layout menu after 
selecting a single object with the arrow tool.

These menu commands affect the layout layer only. To put drawing elements in 
front of the layout layer, use the User Front drawing layer. To put drawing elements behind the layout 
layer, User Back drawing layer.

Aligning Stacked Graph Objects
It is a common practice to stack a group of graphs vertically in a column. Sometimes, only one X axis is used 
for a number of vertically stacked graph. Here is an example.
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This section gives step-by-step instructions for creating a layout like the one above. It is also possible to do 
this using a single graph (see Creating Stacked Plots on page II-293 for details) or using subwindows (see 
Chapter III-4, Embedding and Subwindows).

To align the axes of multiple graph objects in a layout, it is critical to set the graph margins. This is explained 
in detail as follows.

The basic steps are:
1. Prepare the graphs.
2. Append the graph objects to the layout.
3. Align the left edges of the graph objects.
4. Set the width and height of the graph objects.
5. Set the vertical positions of the graph objects.
6. Set the graph plot areas and margins to uniform values.

It is possible to do steps 3, 4, and 5 at once by using the Arrange Objects dialog. However, in this section, 
we will do them one-at-a-time.

Prepare the Graphs
It is helpful to set the size of the graph windows approximately to the size you intend to use in the layout 
so that what you see in the graph window will resemble what you get in the layout. You can do this man-
ually or you can use the MoveWindow operation. For example, here is a command that sets the target 
window to 5 inches wide by 2 inches tall, one inch from the top-left corner of the screen.
MoveWindow/I 1, 1, 1 + 5, 1 + 2

In the example shown above, we wanted to hide the X axes of all but the bottom graph. We used the Axis tab 
of the Modify Graph dialog to set the axis thickness to zero and the Label Options tab to turn the axis labels off.

Append the Graphs to the Layout
Click in the layout window or create a new layout using the New Layout item in the Windows menu. If 
necessary, activate the layout tools by clicking the layout icon in the top-left corner of the layout. Use the 
Graph pop-up menu or the Append to Layout item in the Layout menu to add the graphs. Drag each graph 
to the general area where you want it.

Align Left Edges of Layout Objects
Drag one of the graphs to set its left position to the desired location. Then Shift-click the other graphs to 
select them. Now choose Align→Left Edges from the Layout menu.

Set Width and Height of Layout Objects
Set the width and height of one of the graph objects by selecting it and dragging the resulting handles or by 
double-clicking it and entering values in the Modify Objects dialog.

Click in a blank part of the page to deselect all objects. Now click the object whose dimensions you just set. 
Now Shift-click to select the other graph objects. With all of the graph objects selected, choose Make Same 
Width And Height from the Layout menu.

Set Vertical Positions of Layout Objects
Drag the graph objects to their approximate desired positions on the page. You can drag an object vertically 
without affecting its horizontal position by pressing Shift while dragging. Once you have set the approxi-
mate position, fine tune the vertical positions using the arrow keys to nudge the selected object.

Set Graph Plot Areas and Margins
At this point, your axes would be aligned except for one subtle thing. The width of text (e.g., tick mark 
labels) in the left margin of each graph can be different for each graph. For example, if one graph has left 
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axis tick mark labels in the range of 0.0 to 1.0 and another graph has labels in the range 10,000 to 20,000, Igor 
would leave more room in the left margin of the second graph. The solution to this problem is to set the 
graph margins, as well as the width of the plot areas, of each graph to the same specific value.

To do this, select all of the graph objects and then choose Make Plot Areas Uniform from the Layout menu. 
This invokes the following dialog:

Note that, because we are stacking graphs vertically, we want their horizontal margins and plot areas to be 
the same, which is why we have selected Horizontally from the pop-up menu. The three checkboxes are 
selected because we want to set both the left and right margins as well as the plot area width.

Now click each of the three Estimate buttons. When you click the Estimate button next to the Set Left 
Margins To checkbox, Igor sets the corresponding edit box to the largest left margin of all of the graphs 
selected in the list. Igor does a similar thing for the other two Estimate buttons. As a result, after clicking 
the three buttons, you should have reasonable values. Click Do It.

Now examine the stacked graph objects. It is possible that you may want to go back into the Make Plot 
Areas Uniform dialog to manually tweak one or more of the settings.

After doing these steps, the horizontal plot areas in the stacked graphs will be perfectly aligned. This does 
not, however, guarantee that the left axes will line up. The reason for this is the graphs’ axis standoff set-
tings. The axis standoff setting, if enabled, moves the left axis to the left of the plot area to prevent the dis-
played traces from colliding with the axis. If the graphs have different sized markers, for example, it will 
offset the left axis of each graph by a different amount. Thus, although the plot areas are perfectly-aligned 
horizontally, the left axes are not aligned. The solution for this is to use the Modify Axis dialog (Graph 
menu) to turn axis standoff off for each graph.

Arranging Objects
You can tile or stack objects in a layout by choosing the Arrange Objects item from the Layout menu.
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To arrange objects in a section of the page rather than the whole page, you must use the marquee tool to 
specify the section before invoking the dialog. Then make sure the “Use marquee” checkbox is selected.

There are several ways to specify which objects to arrange. Any objects that you select in the Objects to 
Arrange list will be arranged. In addition, you can include the selected object, all graphs, tables, textboxes 
or pictures by enabling the appropriate checkbox. If you select no objects in the list and select none of the 
checkboxes, then all of the objects in the layout will be arranged.

You can set the number of rows and columns of tiles or you can leave them both on auto. If auto, Igor figures 
out a nice arrangement based on the number of objects to be tiled and the available space. Setting rows or 
columns to zero is the same as setting it to auto.

If you set both the rows and columns to a number between 1 and 100, Igor tiles the objects in a grid deter-
mined by your row/column specification. If you set either rows or columns to a number between 1 and 100 
but leave the other setting on auto, Igor figures out what the other setting should be to properly tile the 
objects. In all cases, Igor tiles starting from the top-left cell in a grid defined by the rows and columns, 
moving horizontally first and then vertically.

If the grid that you specify has fewer tiles than the number of objects to be tiled, once all of the available 
tiles have been filled, Igor starts tiling from the top-left corner again.

Regardless of the parameters you specify, Igor clips coordinates so that a tiled object is never completely off 
the page. Also, objects are never set smaller than a minimum size or larger than the page.

The order in which objects are tiled is determined by the order in which they appear in the command gen-
erated by the Arrange Objects dialog. This in turn depends on the front to back ordering of the objects in 
the layout. Objects are tiled from left to right, top to bottom. Therefore, you can control exactly where each 
object winds up by controlling the front to back ordering. Another approach is to use the Arrange Objects 
dialog to compose the Tile command. Then, instead of clicking Do It, click To Cmd Line, putting the Tile 
command in the command line. Now arrange the objects by editing the command line so that they are in 
the order in which you want them tiled. Then press Return or Enter to execute the Tile command.

Printing Graphs as Bitmaps
You can print graphs in layouts using a high-res bitmap rather than the usual object draw method. Use this 
when a printer driver has bugs that affect normal operations. It may also be useful for printing graphs with 
very large numbers of data points. There are drawbacks to the bitmap method. A large amount of memory 
will be needed and on the Macintosh, patterns will be too small to be useful. Also, the quality of lines, 
dashed lines in particular, may be inferior.

To have Igor to print graphs in Layouts using the bitmap method, execute the following on the command line:
Variable/G V_PrintUsingBitmap = 1

Select the objects 
to tile or stack. 
Shift-click to select 
multiple objects.

Select to tile or stack 
into a section of the 
page instead of the 
whole page.

Sets the grid in which 
tiling or stacking is done.

Sets the spacing between 
objects in points.
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This command creates a variable that is stored in the current experiment. You must execute this command 
for each experiment in which you want to use bitmap printing. Also, this variable must be created in the 
root Data Folder.

To return Igor to its default printing settings, set V_PrintUsingBitmap=0 or kill the variable.

Exporting Layouts
You can export a layout to another application through the Clipboard or by creating a file. To export via the 
Clipboard, use the Export Graphics item in the Edit menu. To export via a file, use the Save Graphics item 
in the File menu.

If you want to export a section of the page, use the marquee tool to specify the section first. To do this, the 
layout icon in the top-left corner of the layout window must be selected. If you don’t use the marquee, Igor 
exports the part of the page that has layout objects or drawing elements in it.

The process of exporting graphics from a layout is very similar to exporting graphics from a graph. Because 
of this, we have put the details elsewhere: Chapter III-5, Exporting Graphics (Macintosh), and Chapter 
III-6, Exporting Graphics (Windows). These chapters describe the various export methods and how to 
select the method that will give you the best results.

Copying Objects from the Layout Layer
You can copy objects to the Clipboard by selecting them with the arrow tool or enclosing them with the 
marquee tool and then choosing Copy from the Edit menu. You can also choose Copy from the pop-up 
menu that appears when you click inside the marquee.

When you copy an object to the Clipboard, it is copied in two formats:
• As an Igor object in a format used internally by Igor
• As a picture that can be understood by other applications

Although you can do a copy for the purposes of exporting to another application, this is not the best way. 
See Exporting Layouts on page II-387 for a discussion of exporting graphics to another application. This 
section deals with copying objects for the purposes of pasting them in the same or another layout. Since it 
is easy to append graphs and tables to a layout using the pop-up menus in the tool palette, the main utility 
of this is for copying annotations or pictures from one layout to another.

Copying as an Igor Object Only
There are times when a straightforward copy operation is not desirable. Imagine that you have some graph 
objects in a layout and you want to put the same objects in another layout. You could copy the graph objects and 
paste them into the other layout. However, if the graphs are very complex, it could take a lot of time and memory 
to copy them to the Clipboard as a picture. If your purpose is not to export to another application, there is really 
no need to copy as a picture. If you press Option (Macintosh) or Alt (Windows) while choosing Copy, then Igor 
will do the copy only as Igor objects, not as a picture. You can now paste the copied graphs in the other layout.

Pasting Objects into the Layout Layer
This section discusses pasting Igor objects that you have copied from the same or a different page layout. 
For pasting a new picture that you have generated with another application, see Inserting a Picture in the 
Layout Layer on page II-377.

To paste layout objects that you have copied to the Clipboard from the same Igor experiment, just choose 
Paste from the Edit menu.

When you copy a graph, table or picture layout object from a layout to the Clipboard, it is copied as a picture 
and as an Igor object, in an internal Igor format. The Igor format includes the name by which Igor knows 
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the layout object. If you later paste into a layout, Igor will use this name to determine what object should 
be added to the layout. It normally does not paste the picture representation of the object. In other words, 
the Igor format of the object that is copied to the Clipboard refers to a graph, table or picture by its name.

In rare cases, you may actually want to paste as a picture, not as an Igor object. You might plan to change 
the graph but want a representation of it as it is now in the layout. To do this, press Option (Macintosh) or 
Alt (Windows) while choosing Edit→Paste. This creates a new named picture in the current experiment.

Pasting into a Different Experiment
The reference in the Clipboard to Igor objects by name doesn’t work across Igor experiments. The second 
experiment may have a different object with the same name or it may have no object with the name stored 
in the Clipboard. The best you can do when pasting from one experiment to another is to paste a picture of 
the object from the first experiment.

You can force Igor to paste the picture representation instead of the Igor object representation as described 
above, by pressing Option (Macintosh) or Alt (Windows) while choosing Edit→Paste.

Pasting Color Scale Annotations
For technical reasons, Igor is not able to faithfully paste a color scale annotation that uses a color index wave 
or that uses the lookup keyword of the ColorScale operation. If you paste such a color scale, Igor will change 
it to a color table color scale annotation with no lookup.

Page Layout Preferences
Page layout preferences allow you to control what happens when you create a new layout or add new 
objects to the layout layer of an existing layout. To set preferences, create a layout and set it up to your taste. 
We call this your prototype layout. Then choose Capture Layout Prefs from the Layout menu.

Preferences are normally in effect only for manual operations, not for programmed operations in Igor pro-
cedures. This is discussed in more detail in Chapter III-17, Preferences.

When you initially install Igor, all preferences are set to the factory defaults. The dialog indicates which 
preferences you have changed.

The “Window Position and Size” preference affects the creation of new layouts only.

The Object Properties preference affects the creation of new objects in the layout layer. To capture this, add 
an object to the layout layer and use the Modify Objects dialog to set its properties. Then select the object 
and choose Capture Layout Prefs. Select the Object Properties checkbox and click Capture Prefs.

The page setup preference affects what happens when you create a new layout, not when you recreate a 
layout using a recreation macro.

Resets preferences for the selected 
items to the factory defaults.

Object properties are captured from the selected 
object. Nothing is captured if no object is selected.

Captures preferences for 
the selected items from the 
active layout window.

Indicates that the current 
page setup is the factory 
default page setup.

Select items that you want 
to capture or revert.
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Layout Style Macros
The purpose of a layout style macro is to allow you to create a number of layouts with the same stylistic 
properties. Using the Window Control dialog, you can instruct Igor to automatically generate a style macro 
from a prototype layout. You can then apply the macro to other layouts.

Igor can generate style macros for graphs, tables and page layouts. However, their usefulness is mainly for 
graphs. See Graph Style Macros on page II-300. The principles explained there apply to layout style macros also.

Problems with Layouts
This section discusses problems that some people may encounter in using page layouts.

Picture Transparency
A picture is inherently opaque if the picture itself erases its own background. For a picture that you create 
in a drawing program, this would be the case if you drew a white rectangle behind all of the other elements 
in the picture. If a picture is inherently opaque, you can’t make it transparent by changing the layout trans-
parency property. It will always print opaque.

Graphs Transparency
A graph with a nonwhite background color is inherently opaque. You can’t make it transparent by chang-
ing the layout transparency property. It will always print opaque.

Transparency on Screen and in the Printout
The part of Igor that draws layout objects in the layout window is not smart enough to recognize when an 
object is inherently opaque. Because of techniques used in drawing the screen, if you set an inherently 
opaque object to transparent, it will appear transparent in the layout window but will print opaque.
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Page Layout Shortcuts
Action Shortcut (Macintosh) Shortcut (Windows)

Change the layout 
magnification

Click the magnification readout in the 
lower-left corner of the layout window.

Click the magnification readout in the 
lower-left corner of the layout window.

Modify layout object 
properties

Select the arrow tool in Layout mode and 
double-click the object.

Select the arrow tool in Layout mode and 
double-click the object.

Edit an existing 
annotation

Select the annotation tool in the Layout 
mode and click in the annotation.

Select the annotation tool in the Layout 
mode and click in the annotation.

Bring up a graph or 
table window

Select corresponding object in the 
layout layer and then double-click the 
name of the object in the info panel.

Select corresponding object in the 
layout layer and then double-click the 
name of the object in the info panel.

Auto-size a picture or 
annotation object to 
100%

Select arrow tool in Layout mode, press 
Option and double-click the picture or 
annotation object.

Select arrow tool in Layout mode, press 
Alt and double-click the picture or 
annotation object.

Auto-size a table object 
to an integral number 
of rows and columns

Select arrow tool in Layout mode, press 
Option and double-click the table 
object.

Select arrow tool in Layout mode, press 
Alt and double-click the table object.

Constrain the resizing 
direction or dragging 
an object

Press Shift while resizing or dragging 
the object.

Press Shift while resizing or dragging 
the object.

Copy, cut, or clear 
multiple layout objects

Use the arrow tool or marquee tool to 
select the objects, then choose copy, cut 
or clear from the Edit menu.

Use the arrow tool or marquee tool to 
select the objects, then choose copy, cut 
or clear from the Edit menu.

Export a subset of the 
layout via the 
Clipboard

Using the marquee tool, select a page 
area, then choose Export Graphics from 
the Edit menu.

Using the marquee tool, select a page 
area, then choose Export Graphics from 
the Edit menu.

Export a subset of the 
layout via the a 
graphics file

Using the marquee tool, select a page 
area and then choose Save Graphics 
from the File menu.

Using the marquee tool, select a page 
area and then choose Save Graphics 
from the File menu.

Drawing tool shortcuts See Chapter III-3, Drawing. See Chapter III-3, Drawing.
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