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Overview
This chapter discusses exporting graphics from Igor graphs, page layouts, tables, and Gizmo plots to 
another program on Macintosh. You can export graphics through the clipboard by choosing Edit→Export 
Graphics, or through a file, by choosing File→Save Graphics.

Igor Pro supports a number of different graphics export formats. You can usually obtain very good results 
by choosing the appropriate format, which depends on the nature of your graphics and the characteristics 
of the program to which you are exporting.

Unfortunately, experimentation is sometimes required to find the best export format for your particular cir-
cumstances. This section provides the information you need to make an informed choice.

This table shows the available graphic export formats on Macintosh:

PDF Format
PDF (Portable Document Format) is Adobe's platform-independent vector graphics format that has been 
adopted by Apple as the standard graphics format for OS X. This is the best format as long as your destina-
tion program supports it.

The Quartz PDF format is generated by the operating system and consequently is more capable than Igor's 
existing native PDF generator. For example, it does a better job of embedding fonts and fully supports 
imported pictures.

Export Format Export Method Notes

Quartz PDF Clipboard, file The standard format for OS X. Best format for general use. Generated 
via the operating system and consequently more capable than Igor 
PDF.

LowRes PDF Clipboard, file Mostly just a compatibility placeholder for the legacy Macintosh 
PICT format. May have specialized uses but generally should not 
be used. Igor PDF does not support transparency. Use Quartz PDF 
instead.

Igor PDF Clipboard, file PDF generated by Igor's own code rather than by the OS. May have 
specialized uses but generally should not be used. Use Quartz PDF 
instead.

EPS 
(Encapsulated 
Postscript)

File only Platform-independent.

Supports high resolution.

EPS does not support transparency.

Useful only when printing on a PostScript printer, creating a PDF file, 
or exporting to PostScript-savvy program (e.g., Adobe Illustrator, Tex).

PNG 
(Portable Network 
Graphics)

Clipboard, file Platform-independent bitmap format.

Uses lossless compression. Supports high resolution.

JPEG Clipboard, file Platform-independent bitmap format.

Uses lossy compression. Supports high resolution.

TIFF Clipboard, file Platform-independent bitmap format.

Supports high resolution but not compression.

SVG Clipboard, file Platform-independent vector graphics format. A good choice if the 
destination program supports SVG.
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The Igor PDF format is generated by Igor's own code rather than by the OS. Due to the following limita-
tions, it should not be used unless you need to export in CMYK color mode; see Exporting Colors on page 
III-93 for details. The limitations of Igor PDF are:

• If the window contains any drawings imported into Igor from other programs, they are rendered 
in the PDF as opaque bitmap images. 

• You need to pay attention to fonts. See Font Embedding on page III-93 and Symbols with EPS and 
Igor PDF on page III-438 for details.

• Transparency and gradient fills are not supported.

Blurry Images in PDF
When Igor exports an image plot, it exports the image as a single image object when possible. However, 
some PDF viewers, most notably Apple's, take it upon themselves to blur the pixels. To get around this, you 
can tell Igor to draw image pixels as individual rectangles using the ModifyImage interpolate keyword 
with a value of -1. You should do this only when necessary as the resulting PDF will be much larger.

Encapsulated PostScript (EPS) Format 
Encapsulated PostScript was a widely-used, platform-independent vector graphics format consisting of 
PostScript commands in plain text form. It usually gives the best quality, but it works only when printed to 
a PostScript printer or exported to a PostScript-savvy program such as Adobe Illustrator. You should use 
only PostScript fonts (e.g., Helvetica).

Encapsulated PostScript was a widely-used platform-independent vector graphics format consisting of 
PostScript commands in plain text form. EPS is largely obsolete but still in use. It usually gives good quality, 
but it works only when printed to a PostScript printer or exported to a PostScript-savvy program such as 
Adobe Illustrator. You should use only PostScript fonts such as Helvetica. EPS does not support transpar-
ency.

Prior to Igor Pro 7, Igor embedded a screen preview in EPS files. This is no longer done because the preview 
was not cross-platform and caused problems with many programs.

EPS files normally use the RGB encoding to represent color but you can also use CMYK. See Exporting 
Colors on page III-93 for details.

Igor Pro exports EPS files using PostScript language level 2. This allows much better fill patterns when 
printing and also allows Adobe Illustrator to properly import Igor’s fill patterns. For backwards compati-
bility with old printers, you can force Igor to use level 1 by specifying /PLL=1 with the SavePICT operation.

If the graph or page layout that you are exporting as EPS contains a non-EPS picture imported from another 
program, Igor exports the picture as an image incorporated in the output EPS file.

Igor can embed TrueType fonts as outlines. See Font Embedding on page III-93 and Symbols with EPS and 
Igor PDF on page III-438 for details.

SVG Format
SVG (Scalable Vector Graphics) is an XML-based platform-independent 2D vector and raster graphics format 
developed by the World Wide Web Consortium. It is often used for displaying graphics in web pages and is 
a good choice for other uses if the destination program supports it.

Platform-Independent Bitmap Formats
PNG (Portable Network Graphics) is a platform-independent bitmap format that uses lossless compression 
and supports high resolution. It is a superior alternative to JPEG or GIF. Although Igor can export and 
import PNG images via files and via the clipboard, some programs that allow you to insert PNG files do 
not allow you to paste PNG images from the clipboard.



Chapter III-5 — Exporting Graphics (Macintosh)

III-92

JPEG is a lossy image format whose main virtue is that it is accepted by all web browsers. However all 
modern web browsers support PNG so there is little reason to use JPEG. Although Igor can export and 
import JPEG via the clipboard, not all programs can paste JPEGs.

TIFF is an Adobe format often used for digital photographs. Igor’s implementation of TIFF export does not 
use compression. TIFF files normally use the RGB scheme to specify color but you can also use CMYK. See 
Exporting Colors on page III-93 for details. There is no particular reason to use TIFF over PNG unless you 
are exporting to a program that does not support PNG. Igor can export and import TIFF via files and via 
the clipboard and most graphics programs can import TIFF.

Choosing a Graphics Format
Because of the wide variety of types of graphics, destination programs, printer capabilities, operating 
system behaviors and user-priorities, it is not possible to give definitive guidance on choosing an export 
format. But here is an approach that will work in most situations.

If the destination program accepts PDF or SVG, then they are probably your best choice because of their 
high-quality vector graphics and platform-independence.
Encapsulated PostScript (EPS) is also a very high quality format which works well if the destination 
program supports it.

If SVG, PDF and EPS are not appropriate, your next choice would be a high-resolution bitmap. The PNG 
format is preferred because it is platform-independent and is compressed. If the application to which you 
are exporting does not support PNG, your next choice would be TIFF or JPEG.

Exporting Graphics Via the Clipboard
To export a graphic from the active window via the clipboard, choose Edit→Export Graphics. This displays 
the Export Graphics dialog.

When you click the OK button, Igor copies the graphics for the active window to the clipboard. You can 
then switch to another program and do a paste.

When a graph, page layout, or Gizmo plot is active and in operate mode, choosing Edit→Copy copies to 
the clipboard whatever format was last used in the Export Graphics dialog. For a table, Edit→Copy copies 
the selected numbers to the clipboard and does not copy graphics.

When a page layout has an object selected or when the marquee is active, choosing Edit→Copy copies an 
Igor object in a format used internally by Igor along with a PDF and does not use the format from the Export 
Graphics dialog

Although Igor can export a number of different formats, not all programs can recognize them on the clip-
board. You may need to export via a file.

Igor can export PNG images to the clipboard and can then paste them back in. On the Macintosh, the clip-
board type is 'PNGf' but because there is no standard for PNG on the clipboard it is therefore unlikely that 
other programs can import them except as files.

Exporting Graphics Via a File
To export a graphic from the active window via a file, choose File→Save Graphics. This displays the Save 
Graphics File dialog.

The controls in the Format area of the dialog change to reflect options appropriate to each export format.

When you click the Do It button, Igor writes the graphic to a file. You can then switch to another program 
and import the file.
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If you select _Use Dialog_ from the Path pop-up menu, Igor presents a Save File dialog in which you can 
specify the name and location of the saved file.

Exporting a Graphic File for Transfer to a Windows Computer
The best method for transferring Igor graphics to a Windows computer is to transfer the entire Igor exper-
iment file, open it in Igor for Windows, and export the graphic via one of the Windows-compatible methods 
available in Igor for Windows.

If your graph or layout contains embedded pictures in PDF format, you will need to convert them to the 
cross-platform format, PNG, because PDFs are not displayed in Igor for Windows. If any embedded pic-
tures are in JPEG, TIFF, or SVG formats, these will work without conversion. See Chapter III-15, Platform-
Related Issues, especially the section Picture Compatibility on page III-399.

If you don’t have a copy of Igor for Windows available, you have these choices:
1. Export SVG or PDF if the destination program can accept it.
2. Export an EPS file. This works only if the Windows program can import EPS files, and requires that 

it be printed on a PostScript printer.
3. Export a PNG.

Exporting a Section of a Layout
To export a section of a page layout, use the marquee tool to identify the section and then choose 
Edit→Export Graphics or File→Save Graphics.

If you don’t use the marquee and the Crop to Page Contents checkbox is checked, Igor exports the area of 
the layout that is in use plus a small margin. If it is unchecked, Igor exports the entire page.

Exporting Colors
The PDF, EPS and TIFF graphics formats normally use the RGB scheme to specify color. Some publications 
require the use of CMYK instead of RGB, although the best results are obtained if the publisher does the 
RGB to CMYK conversion using the actual characteristics of the output device. For those publications that 
insist on CMYK, you can use the SavePICT /C=2 flag

Font Embedding
You can embed TrueType fonts in EPS files and in PDF files. This means you can print EPS or PDF files on 
systems lacking the equivalent PostScript fonts. This also helps for publications that require embedded fonts.

Font embedding is done automatically for the Quartz PDF format and you do not need to bother with this 
section unless you are using EPS or Igor PDF formats.

In Igor Pro 7 font embedding is always on and the only option is to not embed standard fonts. For most 
purposes, embedding only non-standard fonts is the best choice.

Igor embeds TrueType fonts as synthetic PostScript Type 3 fonts derived from the TrueType font outlines. 
Only the actual characters used are included in the fonts.

Not all fonts and font styles on your system can be embedded. Some fonts may not allow embedding and 
others may not be TrueType or may give errors. Be sure to test your EPS files on a local printer or by import-
ing into Adobe Illustrator before sending them to your publisher. You can test your PDF files with Adobe 
Reader. You can also use the “TrueType Outlines.pxp” example experiment to validate fonts for embed-
ding. Choose Files→Example Experiments→Feature Demos 2→TrueType Outlines.

For EPS, Igor determines if a font is non-standard by attempting to look up the font name in a table 
described in PostScript Font Names (OS X) on page III-94 after doing any font substitution using that table. 
In addition, if a nonplain font style name is the same as the plain font name, then embedding is done. This 
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means that standard PostScript fonts that do not come in italic versions (such as Symbol), will be embedded 
for the italic case but not for the plain case.

For PDF, non-standard fonts are those other than the basic fonts guaranteed by the PDF specification to be built-
in to any PDF reader. Those fonts are Helvetica and Times in plain, bold, italic and bold-italic forms as well as 
Symbol and Zapf Dingbats only in plain style. If embedding is not used or if a font can not be embedded, fonts 
other than those just listed will be rendered as Helvetica and will not give the desired results.

PostScript Font Names (OS X)
When generating PostScript, Igor needs to generate proper PostScript font names. This presents problems 
under Macintosh OS X. Igor also needs to be able to substitute PostScript fonts for non-PostScript fonts. 
Here is a list of font names that are translated into the standards:

TrueType Name PostScript Name

Helvetica Helvetica

Arial Helvetica

Helvetica-Narrow Helvetica-Narrow

Arial Narrow Helvetica-Narrow

Palatino Palatino

Book Antiqua Palatino

Bookman Bookman

Bookman Old Style Bookman

Avant Garde AvantGarde

Century Gothic AvantGarde

New Century Schlbk NewCenturySchlbk

Century Schoolbook NewCenturySchlbk

Courier Courier

Courier New Courier

Zapf Chancery ZapfChancery

Monotype Corsiva ZapfChancery

Zapf Dingbats ZapfDingbats

Monotype Sorts ZapfDingbats

Symbol Symbol

Times Times

Times New Roman Times
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